Cyclone external image problem

Discuss all Cyclone related issues here.
Post Reply
GeoNature
I have made <0 posts
I have made <0 posts
Posts: 7
Joined: Sun Jun 14, 2015 5:07 pm
Full Name: Vito Muscio
Company Details: Geological consulting
Company Position Title: Geologist
Country: Italy
Linkedin Profile: Yes

Cyclone external image problem

Post by GeoNature » Sat Oct 19, 2019 8:28 am

Hi friends..

im using a Cyclone (9.2.1) to color point cloud using external panoramic image..

The match works some time well and sometime bad (match images to scan).. I dont' know why..

I export the scan registered (e57) with magnet collage and after i import in cyclone..

I think that some scan don't preserve during the import the axis origin, i dont' have other explanation.

who help me?
1.PNG
color.PNG
intennsity.PNG
You do not have the required permissions to view the files attached to this post.

Tookie
I have made 80-90 posts
I have made 80-90 posts
Posts: 85
Joined: Thu Sep 21, 2017 9:43 pm
Full Name: Iain Took
Company Details: WMP
Company Position Title: Dogsbody
Country: United Kingdom
Linkedin Profile: No
Been thanked: 1 time

Re: Cyclone external image problem

Post by Tookie » Sat Oct 19, 2019 9:11 am

I've not had much luck with the auto Pano import when close to objects like your cliff face.

You can manually align the cube faces which should work okay. Look up texture mapping in the help menu.

c2a
I have made <0 posts
I have made <0 posts
Posts: 4
Joined: Fri Oct 18, 2019 8:00 pm
Full Name: Corey Weiner
Company Details: C2A Studio
Company Position Title: Founder
Country: United States
Has thanked: 1 time

Re: Cyclone external image problem

Post by c2a » Mon Oct 21, 2019 12:17 pm

My 360 photos also look really bad when exported from Cyclone. Both E57 and RCP photos are terrible however when I export the photo alone, it looks ok. Does anyone else have this problem?

User avatar
gsisman
V.I.P Member
V.I.P Member
Posts: 296
Joined: Fri Oct 07, 2016 1:51 pm
Full Name: Steve Long
Company Details: Montgomery County DOT _ MD
Company Position Title: Land Survey Supervisor
Country: United States
Skype Name: gsisman1
Linkedin Profile: Yes
Has thanked: 49 times
Been thanked: 11 times

Re: Cyclone external image problem

Post by gsisman » Mon Oct 21, 2019 10:00 pm

c2a wrote:
Mon Oct 21, 2019 12:17 pm
My 360 photos also look really bad when exported from Cyclone. Both E57 and RCP photos are terrible however when I export the photo alone, it looks ok. Does anyone else have this problem?
Current Cyclone does not export a true Pano to E57 or RCP that is "read" in Recap in the photo bubbles. It sends a Pseudo pano (a picture of the colorized pointcloud, but the pixels are blended to form a picture background of sorts -no Sky just black & black outlines around foreground objects vs background objects). This is SUPPOSED to be corrected in the next release according to an earlier post by Guy Cutting of Leica this past June.
BTW exports panos fine to an e57 that is read by their OWN software.

See this current post also:
https://laserscanningforum.com/forum/vi ... 46&t=15372

Rikore
V.I.P Member
V.I.P Member
Posts: 335
Joined: Sun Aug 16, 2015 6:48 pm
Full Name: Bruce Yager
Company Details: Rikore Geomatics
Company Position Title: Department Head
Country: USA
Linkedin Profile: No
Been thanked: 3 times

Re: Cyclone external image problem

Post by Rikore » Tue Oct 22, 2019 11:42 am

This has been an on going problem since 9.3 for us. The issue has been raised with Leica support several times but falls on deaf ears I'm afraid. Its a 80 to 90 percent chance they align right. We have tried to adjust the nodal ninja settings, but still the same issues. Have the same issues when the camera is mounted on top of the P40. I believe we are stuck with the problem and have to manually align within Cyclone. Somewhere, somehow, a setting changed and the problems began. Our firm has even taught external camera work flows for Leica. Its just a little frustrating and adds a bit of time to align, but the externals are still worth it.

Yuelin
I have made 80-90 posts
I have made 80-90 posts
Posts: 80
Joined: Sat Mar 19, 2011 5:16 am
Full Name: Yuelin
Company Details: Leica Geosystems
Company Position Title: Lead software engineer
Country: USA
Linkedin Profile: No
Been thanked: 3 times

Re: Cyclone external image problem

Post by Yuelin » Tue Oct 22, 2019 5:11 pm

Direct export to Rcp with real view support has already been included in the latest 9.4.2 release. Please check it out.

GeoNature
I have made <0 posts
I have made <0 posts
Posts: 7
Joined: Sun Jun 14, 2015 5:07 pm
Full Name: Vito Muscio
Company Details: Geological consulting
Company Position Title: Geologist
Country: Italy
Linkedin Profile: Yes

Re: Cyclone external image problem

Post by GeoNature » Thu Oct 24, 2019 3:29 pm

Thanks at all..

i have solved, i picked more point to apply the color...
but, when i export a color point cloud via e57, the file haven't a photo, why?

can i export the photo with a correct orientation in my e57file?

thanks

c2a
I have made <0 posts
I have made <0 posts
Posts: 4
Joined: Fri Oct 18, 2019 8:00 pm
Full Name: Corey Weiner
Company Details: C2A Studio
Company Position Title: Founder
Country: United States
Has thanked: 1 time

Re: Cyclone external image problem

Post by c2a » Thu Nov 14, 2019 5:27 pm

Yuelin wrote:
Tue Oct 22, 2019 5:11 pm
Direct export to Rcp with real view support has already been included in the latest 9.4.2 release. Please check it out.
You are using Cyclone Register 360 and checking the RCP box for individual setups and it exports with a real view high-quality 360 pano photo? You have a Publisher Pro license?

Post Reply

Return to “Leica Cyclone”