Scans Not Showing

Discuss all Cyclone related issues here.
Post Reply
User avatar
V.I.P Member
V.I.P Member
Posts: 106
Joined: Tue Mar 31, 2015 12:44 pm
Full Name: Josh K
Company Details: Complete 3D Concepts
Company Position Title: Director
Country: Australia
Linkedin Profile: No
Location: Brisbane, Australia

Scans Not Showing

Post by JoshK »

Hi all, long time no post.

this one is a real head scratcher for me, but hoping someone may be able to help.

i have a registration of 230+ scans that is good (all clouds 3+ constraints and all less the 6mm error). when i first opened the frozen scan world i noticed that there was a big chunk of a building missing. on closer inspection it turned out there were 5 scans that were just not displaying. that is to say they were in the registration, constrained properly and all that, but just not displaying no matter what i tried. after some memory stretching and a bit of menu surfing i turned on the "original scans" (are these the control space scans?) in the Scan World Explorer. they showed and when i turned them back off the other scans were there. and everything looked good. i cleaned up and processed the scans out to Recap.

While working on the job in Autocad i noticed that there were a few other areas that were hard to see the detail inside the other buildings. a bit of interrogation of the cyclone data shows that there are other areas where there are anything from 1 to 4 scans that aren't showing. that is to say all other scans around the area were there and in some cases half of the scan shows but not the whole thing. to make things stranger, some of the scans will show if you rotate the view of the point cloud to just the right angle in cyclone. 1 degree of view rotation either way and they don't show.

to try and give a clearer idea here are some screenshots:

this is the plan view showing the scan locations (purple circles and numbers). you can see the shadow from scan 1 and that scans 2 and 3 should fill that in, but don't.
missing scans.jpg
this is the view rotated slightly around the horizontal axis. you can see here that part of scan 2 is now showing, but not the whole thing. still nothing from scan 3.
missing scans 1.jpg
this is the view from scan 3 end of the point cloud. scan 2 now appears to be showing in full, but still nothing from scan 3 as best i can tell.
missing scans 2.jpg
it is also worth noting that this is a small portion of the cloud copied out to a new model space to get the best view. if i try and view this in the model space that has all the scans i get this.
missing scans 3.jpg
Now i thought at first that this was an issue with the number of points on display vs that number of points in the point cloud at 230+scans. so i bumped that up from the usual 50mil to 100mil and no change.

i also thought that it might have only been a cyclone display issue and that it would still transfer the data out as technically the scans are all there, all of the data is in the scans (both control space and model space scans show in full for all scans if you open them individually). but it appears that as the points aren't being displayed in any way that cyclone is treating them as being invisible or hidden and not exporting them. worst part is this doesn't seem to matter if they are unified or not. the points are there but not showing.

Other things of note, i did the scans with my P30 and the job was done over 3 days on site. so the scans were "broken up" into 3 separate folders on import into the one cyclone project as Day 1 Day 2 and Day 3. all of the scans were worked on as one continuous data set as day 2 started where day 1 finished. I have done this in the past and on bigger jobs (over more days) a few times and not had any issues. the problems are within the individual days worth of scans. that is to say that it isn't where the scans from the days overlap.

the only thing i can think of is that due to taking the scans off the scanner each day and starting a new project on the scanner for the days work, the scan world numbers are the same for the most part. but this has never been an issue in the past so unlikely as best i can tell.

so, short of redoing the whole registration, does anyone have any ideas that may help?

thanks in advance.
You do not have the required permissions to view the files attached to this post.

Post Reply

Return to “Leica Cyclone”