Failed to optimize

Discuss all Leica Geosystems related issues here.
Post Reply
winslowkr
I have made 50-60 posts
I have made 50-60 posts
Posts: 50
Joined: Tue Oct 30, 2018 7:39 pm
Full Name: Kevin Winslow
Company Details: Olsson
Company Position Title: Surveying-Reality Capture-107 UAV Pilot
Country: United States
Linkedin Profile: No
Been thanked: 1 time

Failed to optimize

Post by winslowkr »

I am working on a large Reg360 project 1,050 setups. I realize that this is mostly above what the program is optimized for. I am now getting a "Failed to optimize the given bundle. Encountered numerical issues when attempting to solve."

The bundle is split between 7 sitemaps. I have applied control but removed it trying to fix the issue. I have imported the reg360 project into Cyclone core, but I am lost on how I can fix the registration in Cyc-core.

Any suggestions why this error is coming up and any idea how I might fix it so I can finalize this project.
You do not have the required permissions to view the files attached to this post.
Kevin Winslow
Surveying/Reality Capture/UAV Pilot
Olsson

Rlowry
I have made 10-20 posts
I have made 10-20 posts
Posts: 12
Joined: Fri Mar 29, 2019 10:44 pm
Full Name: Russell Lowry
Company Details: Bi-Con Engineering
Company Position Title: CAD Manager
Country: United States
Linkedin Profile: Yes

Re: Failed to optimize

Post by Rlowry »

got the same message yesterday on a small scan job (15 scans). I restored all the points I had cleaned (a combination of using the detect moving objects tool and some manual cleaning) I was then able to optimize. I'm still doing some testing to see if I can break it again to see what the root cause is...

winslowkr
I have made 50-60 posts
I have made 50-60 posts
Posts: 50
Joined: Tue Oct 30, 2018 7:39 pm
Full Name: Kevin Winslow
Company Details: Olsson
Company Position Title: Surveying-Reality Capture-107 UAV Pilot
Country: United States
Linkedin Profile: No
Been thanked: 1 time

Re: Failed to optimize

Post by winslowkr »

Yep, I think I was getting over zealous with the point cleaning, this was the problem.
Kevin Winslow
Surveying/Reality Capture/UAV Pilot
Olsson

User avatar
topogeo
I have made 70-80 posts
I have made 70-80 posts
Posts: 75
Joined: Fri May 02, 2014 1:38 pm
Full Name: piercarlo roasio
Company Details: studio roasio
Company Position Title: titolare
Country: italy
Linkedin Profile: No
Has thanked: 1 time
Been thanked: 4 times

Re: Failed to optimize

Post by topogeo »

I used manual cleaning (visual points and / or points for C2c) on jobs with 100-200 scans (from RTC360 and BLK360) and I never had any problems finalizing.
I also restore deleted points.
I have NOT tried yet on eliminating moving points.
However, I can't export the RCP file :-(

Piercarlo

User avatar
Carbix
I have made 90-100 posts
I have made 90-100 posts
Posts: 91
Joined: Sat Mar 16, 2019 1:36 am
Full Name: Daniel Loney
Company Details: Excelsior Measuring
Company Position Title: Owner
Country: Canada
Linkedin Profile: Yes
Location: Canada
Has thanked: 8 times
Been thanked: 9 times
Contact:

Re: Failed to optimize

Post by Carbix »

Moving Object detection and clean is deleting the cloud to cloud data but not the intensity data. really dumb odd glitch. unless I'm missing something.
You do not have the required permissions to view the files attached to this post.
Daniel Loney - Owner
Excelsior Measuring inc.
Vancouver - Okanagan - Calgary
www.ExcelsiorLevel.com

KMack
I have made 10-20 posts
I have made 10-20 posts
Posts: 11
Joined: Mon Feb 24, 2020 1:57 am
Full Name: Kirsty Helen
Company Details: Shhhh
Company Position Title: Survey Technician
Country: New Zealand
Has thanked: 8 times

Re: Failed to optimize

Post by KMack »

Did you guys have any further thoughts on this?

I just registered a project in cyclone core (60 scans) but the group would not optimize. I am theorizing that its about cloud to cloud overlap; my cloud had plenty of constraints but mostly target to target, sounds right after what you guys are saying above. Further more I deleted a load of points from the control spaces (trees). After disabling some cloud to cloud constraints it gave me the unable to optimize error message but would still let me register the cloud. It then reported errors of 13 mm but visually the cloud had misalignment which i measured to be 100 mm.

User avatar
gsisman
V.I.P Member
V.I.P Member
Posts: 387
Joined: Fri Oct 07, 2016 1:51 pm
Full Name: Steve Long
Company Details: Montgomery County DOT _ MD
Company Position Title: Land Survey Supervisor
Country: United States
Skype Name: gsisman1
Linkedin Profile: Yes
Has thanked: 114 times
Been thanked: 24 times

Re: Failed to optimize

Post by gsisman »

winslowkr wrote:
Tue Jun 18, 2019 3:50 pm
I am working on a large Reg360 project 1,050 setups. I realize that this is mostly above what the program is optimized for. I am now getting a "Failed to optimize the given bundle. Encountered numerical issues when attempting to solve."

The bundle is split between 7 sitemaps. I have applied control but removed it trying to fix the issue. I have imported the reg360 project into Cyclone core, but I am lost on how I can fix the registration in Cyc-core.

Any suggestions why this error is coming up and any idea how I might fix it so I can finalize this project.
That's a lot of setups. I've had this error before and it has always had to do with removing too many C2C points

Post Reply

Return to “Leica Geosystems”