Dot3D 4.0 Beta with L515 difficulty re-localizing

Discuss all DotProduct related issues here.
Post Reply
User avatar
RorySense
I have made <0 posts
I have made <0 posts
Posts: 3
Joined: Fri May 15, 2020 9:21 am
Full Name: Rory OConnor
Company Details: RemSense
Company Position Title: Senior Engineer
Country: Australia
Linkedin Profile: Yes

Dot3D 4.0 Beta with L515 difficulty re-localizing

Post by RorySense »

I've been evaluating Dot3D version 4.0 (free 1 week licence) with the Realsense L515 and have had a lot of trouble with loss of localization during scanning. I've tested this in high and low resolutions, using April tags, in rooms with all kinds of geometries and found this to be an issue in every case. Often when trying to re-localize I will go back to the same position as I have previously succeeded in re-localizing, with the distinctive geometry threshold hovering consistently at maximum, and it just won't work.

On average, I have found I have to spend over half of the scan time trying to re-localize, and unfortunately if I can't remedy this, it will be the factor that determines whether my company purchases a licence to use commercially in parallel with our terrestrial scanners. I really hope there is a fix as this combination does produce very impressive point clouds that can supplement other terrestrial scan data in hard to access areas.

I understand that this is still a beta version so I'm hoping there are improvements in the works, but if anyone has any advice for me before my trial runs out in a couple of days I would very much appreciate it! :D
Post Reply

Return to “DotProduct”